Network related issues accessing urkund.com domain
Incident Report for Urkund
Resolved
This incident has been resolved. The problem was outside of Urkunds control as this was a relating to Talos making a faulty classification of the urkund.com domain.
Posted Oct 31, 2019 - 13:43 UTC
Investigating
Some customers are reporting network related problems accessing urkund.com domain. This is not a general problem but seems to affect some customers. We are investigating.
Posted Oct 31, 2019 - 10:22 UTC
This incident affected: urkund.com, Urkund Webinbox, and Urkund Plagiarism Detection Result Interface.